Isolation admserv

De wikiGite

Si on doit upgrader les version d'apache ou php sur BlueOnyx, il y a un risque de casser la console d'administration.
Il faut donc l'isoler, donc lui garder ses versions de php et d"apache.

On copie les librairies dans un sous-répertoire admserv :

   cd /usr/lib
   mkdir admserav
   cd admserv
   mkdir httpd
   cp -R ../httpd/* ./httpd/
   cp -R ../php ./

Note: ici on ne s'occupe pas de lib ou lib64, puisque le chemin sera indiqué en dur dans les fichiers de conf : on met donc tout dans /usr/lib, quelque soit l'architecture.

Editer /etc/admserv/conf.d/php.conf. Remplacer

modules/libphp5.so

par :

/usr/lib/admserv/httpd/modules/libphp5.so

Editer /etc/admserv/php.ini. Remplacer

extension_dir = "/usr/lib/php/modules"

par :

extension_dir = "/usr/lib/admserv/php/modules"

Relancer la console :

   /etc/init.d/admserv restart

Après mise à jour : L'upgrade de PHP met en général à jour MySQL en dépendance. Il arrive alors que le PHPMyAdmin inclu avec l'interface ait un problème entre sa librairie 5.0 et le MySQL 5.1 du système. Dans ce cas :

 cd /usr/lib/admserv/php/modules/
 mv mysql.so mysql.so.50
 ln -s /usr/lib/php/modules/mysql.so