Dépôts complémentaires

De wikiGite

Pour chaque rpm ci-dessous, vérifier les dernières versions disponibles à chaque installation

RPMForge

http://wiki.centos.org/AdditionalResources/Repositories/RPMForge

  • Sur CentOaaS4 :
 rpm -Uvh http://packages.sw.be/rpmforge-release/rpmforge-release-0.5.1-1.el4.rf.i386.rpm
  • Sur CentOS5 :
 cd /root/install
 rpm -Uvh http://packages.sw.be/rpmforge-release/rpmforge-release-0.5.2-2.el5.rf.i386.rpm
  • Sur CentOS6 :
 rpm -Uvh http://pkgs.repoforge.org/rpmforge-release/rpmforge-release-0.5.3-1.el6.rf.x86_64.rpm

Puis désactiver ce dépôt par défaut pour éviter des mises à jour intempestives...

 sed -i 's/enabled = 1/enabled = 0/' /etc/yum.repos.d/rpmforge.repo

Remi Collet

(packages plus à jour que les dépôts CentOS standards. Notamment apache, php, mysql,...)

 cd /etc/yum.repos.d
 wget http://rpms.famillecollet.com/remi-enterprise.repo

DAG

(différents outils, htop, mrepo, etc...)

vi /etc/yum.repos.d/CentOS-Dag.repo

Puis coller les lignes suivantes:

[dag]
name=Dag RPM Repository for Red Hat Enterprise Linux
baseurl=http://apt.sw.be/redhat/el$releasever/en/$basearch/dag
gpgcheck=1
gpgkey=http://dag.wieers.com/rpm/packages/RPM-GPG-KEY.dag.txt
enabled=0

EPEL

(Extra Packages for Enterprise Linux)

RH5/CentOS5, i386

 rpm -UvH http://mirrors.ircam.fr/pub/fedora/epel/5/i386/epel-release-5-4.noarch.rpm

RH6/CentOS6, x86_64

 rpm -Uvh http://mirrors.ircam.fr/pub/fedora/epel/6/x86_64/epel-release-6-8.noarch.rpm
 sed -i 's/enabled=1/enabled=0/' /etc/yum.repos.d/epel.repo

Si un message de ce genre apparaît :

erreur: Dépendances requises:
       rpmlib(FileDigests) <= 4.6.0-1 est nécessaire pour epel-release-6-5.noarch
       rpmlib(PayloadIsXz) <= 5.2-1 est nécessaire pour epel-release-6-5.noarch

Essayer de charger plutôt EPEL-5.4

 rpm -Uvh http://download.fedoraproject.org/pub/epel/5/i386/epel-release-5-4.noarch.rpm
 sed -i 's/enabled=1/enabled=0/' /etc/yum.repos.d/epel.repo

RH7/CentOS7, x86_64

 yum install epel-release
 sed -i 's/enabled=1/enabled=0/' /etc/yum.repos.d/epel.repo

Fedora Fusion

Attention, paquets notoirement instables ! S'assurer que EPEL (ci-dessus) est installé ET ENABLED=1 dans epel.repo !

 rpm -Uvh http://download1.rpmfusion.org/free/el/updates/testing/6/i386/rpmfusion-free-release-6-0.1.noarch.rpm http://download1.rpmfusion.org/nonfree/el/updates/testing/6/i386/rpmfusion-nonfree-release-6-0.1.noarch.rpm
 sed -i 's/enabled = 1/enabled = 0/' /etc/yum.repos.d/rpmfusion-free-updates.repo
 sed -i 's/enabled = 1/enabled = 0/' /etc/yum.repos.d/rpmfusion-free-updates-testing.repo
 sed -i 's/enabled = 1/enabled = 0/' /etc/yum.repos.d/rpmfusion-nonfree-updates.repo
 sed -i 's/enabled = 1/enabled = 0/' /etc/yum.repos.d/rpmfusion-nonfree-updates-testing.repo